読者です 読者をやめる 読者になる 読者になる

やってみる

アウトプットすべく己を導くためのブログ。その試行錯誤すらたれ流す。

rbenvでRuby2.4.0をインストールできなかった

前回のつづき。

Ruby

https://www.ruby-lang.org/ja/downloads/

2017/02/24時点では2.4.0が最新の安定版らしい。

rbenvでRubyをインストールする

rbenv で ruby の環境を整える - Qiita

以下のコマンドで実行と確認ができそう。

rbenv install 2.4.0
rbenv global 2.4.0
ruby -v

失敗

$ rbenv install 2.4.0
ruby-build: definition not found: 2.4.0

2.4.0が見つからない。そんなバカな。

upgrade

rbenvでインストールできるバージョンリストを最新にする - Qiita

こちらによるとruby-buildのupdate,upgradeが必要らしい。感謝。

brew update && brew upgrade ruby-build

LinuxMintのコマンドにすると、多分以下のような感じだろう。

sudo apt-get update rbenv
sudo apt-get upgrade rbenv
sudo apt-get update ruby-build
sudo apt-get upgrade ruby-build

だめだった。

$ sudo apt-get update rbenv
[sudo] password for mint: 
E: update コマンドは引数をとりません

一体どうやってupdateするのやら。

インストールできるバージョン一覧

$ rbenv install --list
usage: rbenv install VERSION
       rbenv install /path/to/definition

Available versions:
  1.8.6-p383
  1.8.6-p420
  1.8.7-p249
  1.8.7-p302
  1.8.7-p334
  1.8.7-p352
  1.8.7-p357
  1.8.7-p358
  1.9.1-p378
  1.9.2-p180
  1.9.2-p290
  1.9.2-p318
  1.9.2-p320
  1.9.3-dev
  1.9.3-p0
  1.9.3-p125
  1.9.3-p194
  1.9.3-preview1
  1.9.3-rc1
  2.0.0-dev
  jruby-1.6.3
  jruby-1.6.4
  jruby-1.6.5
  jruby-1.6.5.1
  jruby-1.6.6
  jruby-1.6.7
  jruby-1.6.7.2
  jruby-1.7.0-preview1
  maglev-1.0.0
  rbx-1.2.4
  rbx-2.0.0-dev
  ree-1.8.6-2009.06
  ree-1.8.7-2009.09
  ree-1.8.7-2009.10
  ree-1.8.7-2010.01
  ree-1.8.7-2010.02
  ree-1.8.7-2011.03
  ree-1.8.7-2011.12
  ree-1.8.7-2012.01
  ree-1.8.7-2012.02

2.0は開発版のみが対象。このリストを更新したい。

所感

何かを使うために別のものを必要としていたが、結局使えない。本当に使えるようになるのか。そのために何が必要なのか。どれだけの工程を経る必要があるのか。まるで見えない。何もわからない。