やってみる

アウトプットすべく己を導くためのブログ。その試行錯誤すらたれ流す。

ラズパイ4に最新Node.jsをインストールする

 できた。

以前

 Nodeのインストールが古くてGIF化ツールを導入できなかった。

過去記事

 かつての自分が解決していた。この通りにやったらできた。ブログやっててよかったわー。

sudo apt-get install -y nodejs npm
sudo npm cache clean
sudo npm install -g n
sudo n stable
$ node -v
v12.14.0
$ npm -v
6.13.4

 apt-getで入れた古いのを削除する。(削除しなくてもいいかもしれない)

sudo apt-get purge -y nodejs npm

 パス設定とかしなくても最新バージョンを参照してくれた。

$ node -v
v12.14.0
$ npm -v
6.13.4

対象環境

$ uname -a
Linux raspberrypi 4.19.75-v7l+ #1270 SMP Tue Sep 24 18:51:41 BST 2019 armv7l GNU/Linux